artykułów: 62
« wróć
Bada · 04.04.12 19:11 · 07.04.12 08:07
W Samsung Wave (S8500) z systemem Bada w wersji niższej niż 2.0, po wejściu na stronę map Google pojawia się informacja:

"Mapy Google wymagają oprogramowania Bada 2.0 lub nowszego.
Uaktualnij oprogramowanie za pośrednictwem Samsung Kies."


Uniemożliwia to skorzystanie z map Google na systemie Bada w wersji niższej niż 2.0.

Jak rozwiązać ten problem bez zmiany wersji systemu Bada ?
Można spróbować zmienić ciąg User Agent przeglądarki telefonu.

uwaga: wpisywanie kodów oraz wszelkie zmiany należy wykonać starannie aby nie popełnić błędu - zmiany wykonywane są na własne ryzyko.

1. Wpisać kod: *#33284*#, następnie zmienić "Debug level" na "Mid" (po zapisaniu zmian zostanie wymuszoy restart telefonu).

2. (po uruchomieniu telefonu) Wpisać kod: *#7092463*#, przejść do: "Module Settings", następnie: "Browser", i w końcu do:"UAgent".

W ciągu identyfikującym Twoją przeglądarkę (tak przeglądarka prezentuje się m.in. w mapach Google) należy zmienić wersję systemu Bada na 2.0:

oryginalny ciąg:
Mozilla/5.0 (SAMSUNG; SAMSUNG-GT-S8500/S8500XXJL2; U; Bada/1.2; pl-pl) AppleWebKit/533.1 (KHTML, like Gecko) Dolfin/2.2 Mobile WVGA SMM-MMS/1.2.0 OPN-B

po zmianach:
Mozilla/5.0 (SAMSUNG; SAMSUNG-GT-S8500/S8500XXJK1; U; Bada/2.0; pl-pl) AppleWebKit/533.1 (KHTML, like Gecko) Dolfin/2.2 Mobile WVGA SMM-MMS/1.2.0 OPN-B

3. Wpisać ponownie kod: *#33284*#, zmienić "Debug level" na "Low" (po zapisaniu zmian zostanie wymuszoy restart telefonu).


Powyższa modyfikacja ciągu przeglądarki (UAgent) oraz poprawne działanie map Google zostały zweryfikowane na Samsung Wave (S8500) z wersją systemu 1.2.